lundi 10 décembre 2007

What you need to use these functionalities

-





If you want to use these functionalities, and store 3D models in PostGIS, you first must have an installation of postgreSQL. You can get it on its website.


You also must install the following softwares:



  • PROJ4

Proj4 is a Cartographic Projections Library. You can download it on its website



  • GEOS

Geometry Engine Open Source is a library of geometry computation

You must install the version which is available on this blog if you want to use the 3D functionalities.



download GEOS




  • POSTGIS

A plugin for PostgreSQL which allows to store geographic data.
You also need the version available on this blog to use the 3D functionalities.



download PostGIS







After installing PostgreSQL, you must install the other softwares in the following order:


  1. PROJ4
  2. GEOS
  3. PostGIS.




  • INSTALLATION OF PROJ4:


execute these commands in the root directory:



_____________________

./configure
make
sudo make install
sudo ldconfig
_____________________







  • INSTALLATION OF GEOS


execute these commands in the root directory:



_____________________

./configure

make
sudo make install
sudo ldconfig
_____________________






  • INSTALLATION OF POSTGIS


execute these commands in the root directory:



______________________________________________

./configure --with-proj --with-geos --with-pgsql

make
sudo make install
______________________________________________





Now, you're ready to store 3D models in PostGIS.





-

3 commentaires:

jdc a dit…

Mathieu,

I'm curious as to what the feedback has been from the PostGIS team on integrating your patches and distributing your import/export tools. I don't see any response from them on the mailing list.

Also, do you know if any of the 2005 work of Deni Suwardhi had been considered by the committers? The problems solved probably have changed with evolving standards since them, but it looks like there was work done to support TriangularSurface, Solid, Tetrahedron, Voxel, TetrahedronMesh, TriangularMesh etc.

Thanks,

Jerritt
collord@collord.net

Carlo a dit…

I'm a PhD student and I'm studying systems of survey (as scanner laser)and them rappresentation. I am very interested in your management system and I tried to install it but have not succeeded. What is the configuration to use this system?
I have tried with debian, ubuntu 8.04 and postgres 8.2 but during the installation of your GEOS and PostGIS I had problems with compilers. thank you very much.
Carlo Battini
carlo.battini@gmail.com

cherry mae a dit…

hi. . I have read all the your pages relating to collada2pgsql but as I have researched, I never encountered collada2pgsql tool or library. How will I use collda2pgsql? I really would like to import my 3D models into postgis. .Can you help me? thanks in advance. .